Missing file in 0.9.7 clean install

Am getting the following System Error dialog after a clean install of 0.9.7 on a Win7 Pro 64-bit machine.

The program can’t start because api-ms-win-core-path-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

I tried reinstalling. No joy. I initially tried installing over another version, but got different errors.

Hi @wired,

The problem is that the Joulescope UI no longer supports Windows 7 x64. We, unfortunately, had to drop Windows 7 support with the last two releases (0.9.7 and 0.9.3). As you know, Microsoft dropped Windows 7 in Jan 2020 (more than a year ago), and most of our dependencies are dropping Windows 7 support.

However, if you really need to run on a Windows 7 x64 machine, for now, you still have two choices. You can either:

  1. Install Joulescope UI 0.9.2, which still runs on Win 7.
  2. Run from the command line.
    a. Install Python 3.8.9. Be sure to check add to path. Note python 3.9 will not work.
    b. Open a command prompt
    c. Type: pip3 install -U joulescope_ui
    d. Then to run the Joulescope UI, type: joulescope

Depending upon which software and service packs are installed on your Win 7 machine, you may also need the install the INF files. See here.

Do either of these options work for you?

I’ll just run an older version on this machine. All other machines are at Win10 and I can run on one of them if I need annotations.

1 Like