Frequent crashes in 0.6.8

I just upgraded to version 0.6.8 and I have frequent (every few minutes) crashes. I did not find out a pattern. I work on Win10 64 bit and use the USB front plate.

Hi @sensorsiot and welcome to the forum! We have several people reporting that removing markers in the oscilloscope waveform view causes crashes. We have tracked down the issue, and we have a fix implemented that should be out next week. You can find some details about this on GitHub Issue #29, but also have private confirmation from a couple other people.

Does this sound like the problem that you are seeing?

I did not use markers, so it might be something different. Timing for the moment is not critical as I can do my measurements for my next video also with this software. So I will try again after your corrections.

Ok, so it sounds like your issue is different. Do you have a few minutes to send me the Joulescope log file so that I can troubleshoot this issue? If so, could you use Windows File Explorer and navigate to to your hidden AppData\Local directory:


But replace {username} with your username. The Joulescope log file name is the date/time stamp. If you could post the most recent couple of logs here or send as a DM through the forum, I would appreciate it!

joulescope_20191112_104012_20348.log (3.3 KB) joulescope_20191114_191046_1176.log (9.1 KB) joulescope_20191114_191138_11904.log (41.5 KB) joulescope_20191114_192145_9784.log (114.0 KB) joulescope_20191114_193211_11196.log (20.2 KB) joulescope_20191114_195217_14164.log (18.5 KB) joulescope_20191114_200553_21728.log (22.4 KB) joulescope_20191114_201445_15440.log (134.1 KB) joulescope_20191114_201716_26564.log (240.6 KB) joulescope_20191114_202630_21940.log (2.1 KB) joulescope_20191114_203423_9856.log (1.9 KB) joulescope_20191114_204349_6204.log (1.9 KB) joulescope_20191114_205414_10172.log (2.5 KB) joulescope_20191114_211037_17152.log (2.5 KB)

1 Like

Here you have the logs: I use an Arduino Nano 33 BLE as a load. And when it uploaded and disconnect USB the program seems to crash.

1 Like

Thank you @sensorsiot for taking the time to post the logs and the additional information. This issue is new, and we have not heard about it before. The logs did capture the crash, and has some good information. We will investigate.

1 Like

I just want to say, Andreas, that I’m a big fan of your YouTube channel! I enjoyed it very much a year or two ago when working on a LPWAN project that never happened, then rediscovered it just a day or two ago, as I have a new client interested in the technology. It’s a nice surprise and coincidence to run into you here just now!

I’m also running 0.6.8 under Win 10 64-bit but I only experience crashes when using markers.

Hi @sensorsiot. I took a look through the logs, and I have a two questions:

  1. If you keep the USB computer connections the same but connect the Arduino Nano BLE 33 directly to the computer (no Joulescope in the middle), do you see the same Joulescope UI crashes when you upload Arduino Nano BLE 33 firmware?

  2. How are Arduino Nano BLE 33 and Joulescope’s host USB connected to the host computer? Directly to USB ports on the host? Any USB hubs or docks?

Your answers will help reduct the scope, hopefully to exclude Joulescope’s sensor-side. Thanks!

It looks like you had been running 0.6.3, and you upgraded to 0.6.8. The common error is:

Windows fatal exception: access violation

which usually means some type of memory corruption (such as use after free or bad pointer reference) in the program. Unfortunately, the logs show this occurring in a number of different places. I created Issue #30 on GitHub with details of what I have found so far. I suspect some USB interaction between the Joulescope UI driver and the Arduino Nano 33 BLE. I ordered a Arduino Nano 33 BLE to see if I can duplicate the issue, which will make it much quicker to identify the true root cause.

Sorry for my late answer, but it was late in Europe…
First of all, after a good sleep, this morning the Joulescope did not crash anymore. I tried it with several Arduino boards.
You are probably right, that it is has to do with power, but I do not know, what. Because I wanted to reduce the risk for a ground loop and I needed the Joulescope and the DUT on USB I inserted a USB insulator in the USB for the Arduino between the USB Hub and the Joulescope. The Joulescope is connected directly to the USB hub.Maybe it is not needed, I am not sure. But maybe you have a “best practice” for this common situation?

No worries! I sleep, too :smile:

Good to hear that your system is now working.

What USB isolator were you using? Is that USB hub powered? Something could be browning out. Regardless, the Joulescope UI software should not crash like you observed. We have tested a lot of scenarios, but I am not sure if we have sufficiently tested a partial brown-out on the Joulescope instrument. I will be investigating. I will see if I can duplicate this behavior next week when my Arduino Nano BLE 33 arrives.

If you run into any other issues or have any more information in the meantime, let me know!

I used one of those:

1 Like

Nice video @sensorsiot! Here’s the link:

If anyone wants to jump to where Andreas starts using Joulescope to measure the Nano 33 BLE, click here. He made measurements of the Arduino IoT (SAMD + ESP32) here.

Hi @sensorsiot - I have tried to duplicate the behavior you observed, but I have had no success. I tried programming the Arduino Nano 33 Sense BLE board with a short program (blink) and long programs, like this BLE battery example. As you noted in your video, the compile-time for the Arduino Nano 33 is very painful. I also ordered and received the same USB isolator. Here is a picture of my setup with the Joulescope, USB isolator, and Arduino nano 33 BLE:

We also tried some power glitching on the Joulescope host USB port, but only managed to reset the Joulescope, which is expected. CE testing is pretty brutal on USB devices, so we have good test coverage on USB power issues, but we could be missing some case that you found in your lab. Unfortunately, I don’t have much else to try at the moment. If you have any suggestions, I am happy to try them out!

We will continue to monitor this issue, and I will post here if we receive any similar reports for other Joulescope installations.

If you run across this issue again or find any other issue with your Joulescope, please let me know!

I apologize. I got so caught up in figuring out the issue with the setup that I never answered this question!

Joulescope’s sensor-side is electrically isolated from the USB side. This means that your Joulescope does not introduce any ground loops to your test setup, and your Joulescope measures accurately in most any setup without additional thought. Other (less well designed :wink: ) products require you to think very carefully about ground loops. The only Joulescope requirement is that IN+, IN-, OUT+ and OUT- must all be within ±48V of USB ground. For more details on Joulescope’s isolation, check out page 23 of the 0.6 Joulescope User’s Guide.