Corrupted or not able to open JLS File in the Viewer

I have a JLS file, as big as 50GB. During the measurements, all went okay. Trying to open it now I am not able to see any track. I tried to execute python the Pyjls info, i got all the information that contained the file, looks good. I tried also to open it with the Python program, i got the following error:

Any suggestion on how can I read the file or recover it?
The file contains 3 tracks, 0 annotations, 1 voltage, 2 current.

From that error, it sounds like the JLS file was not closed properly. We have made a bunch of improvements over the last few months to both prevent this from happening and to handle it. What version of the Joulescope UI are you using?

Regardless, you will hopefully be able to recover the data using the JLS copy command, which essentially replays the JLS capture into a new file.

First, ensure that you are up to date:

python -m pip install -U pyjls

And then run the command:

python -m pyjls copy <src> <dst>

Replace <src> with the path to your recorded file that will not open, and replace <dst> with a different output file path. You should then be able to open <dst> in the Joulescope UI.

Does this work?

Is Copy the right command? error: argument subparser_name: invalid choice: ‘copy’ (choose from ‘annotate’, ‘export’, ‘info’, ‘plot’, ‘help’)

Trying EXPORT i get this error: Unsupported outfile extension: .jls

Btw the SW is one of the last versions

I updated the pyjls, it is doing something

It worked, thank you!!

Did you run the upgrade command:

python -m pip install -U pyjls

You can then display the version:

> python -c "import pyjls; print(pyjls.__version__)"

And you find help for the command:

> python -m pyjls copy --help
usage: copy [-h] [--no-progress] src dst

positional arguments:
  src            JLS input filename
  dst            JLS output filename

  -h, --help     show this help message and exit
  --no-progress  Hide progress bar.