Fuses will not clear


Awesome product, got not to long ago, and have been using it daily.
But today i accidentally shorted + and - on my DUT, when i was measuring something with a normal multimeter. This of course causes the fuses in the Joulescope to trig. I can clear the fuses when nothing is connected to my joulescope. but as soon as i connect something to try to make some current measurement again, the fuses trig. If i try to clear them when there something connected it just trig again.
and then the sensor status LED goes from green to blinking red fast (More than one blink per second). and the fuse button in the software blinks red.
I tried with a normal multimeter to measure the current flowing to the DUT, which was measured to 2.2 mA. so it is not a short on the DUT.

I am unsure if i accidentally short something internally in it, or what the solution to this is.
Hope you help me resolve this?

kind regards

Hi @MTychsen and welcome to the Joulescope forum! Great to hear that you have been putting your Joulescope to work!

Which fuse is engaging? You can see if you open the Device Control widget, like this:

The Max fuse to the right engages above 4 amps. The Range fuse engages based upon the active current range. If Current range is auto and the maximum range is 10 A, it should never trip. If you select a smaller max range or manually select a range, it will engage on over-current conditions for that range. The two user fuses are fully configurable.

Note that we also still have issue #244. With this issue, the UI cannot clear the fuse if it was engaged before starting the UI. It’s actually a firmware problem that we have already identified and fixed but not deployed. The fix will be bundled with our next major release tentatively planned for end of June.


Both the range and max fuse keeps triggering. Below 2 pictures can be seen. one where i have not connected the DUT to the joulescope, here the fuse engage correctly.
When i connected the DUT and turn on the power supply the fuses triggers as seen in picture 2, when i try to press the fuse engage button, it immediately triggers the fuses again.
I have tried to open and close the software.
Disconnect and reconnect the joulescope, both with and without something connected.
none of this works.
is there a possibility that i may have fried something internally?

kind regards


Hi @MTychsen,

Since introducing the fuse feature, we have not had any reports of Joulescopes damaged to overcurrent. It’s not impossible, just very, very difficult. It is unusual that both fuses engaged. We should be able to test.

  1. If you disconnect the DUT but turn on the power supply, do the fuses trigger?

  2. If not, its likely that you have a short somewhere else in DUT or wiring. In this case, it would be useful to see the zoomed in waveform before the fuses trigger. Keep the power supply powered. Click the Target Power button at the top left to disable power to the DUT. Connect the DUT. Click Target Power again, and the fuses should trip. Click Signal sample streaming to pause the capture. Zoom in in the waveform and share a screenshot.


  1. If he DUT is disconnected but with the supply on, the fuses do not trigger.

  2. I did as asked, and have shared the screenshot below. A large current seems to be flowing through the joule scope at startup, which i suppose triggers the fuse again. I should mention that i had no problem with this DUT, prior to the short.


Here it is zoomed in

Hi @MTychsen,

  1. Great. If the problem was with the JS220, it would likely have tripped the fuses here.

  2. Your JS220 is showing that the DUT is consuming 11 A or more (the JS220 current meaurement has saturated) for 30 milliseconds before the fuse engages. This looks like your JS220 is operating correctly.

Do you expect your DUT to consume > 11 A for 30 milliseconds at power on? I am guessing not :wink:

I recommend double checking your wiring just to make sure that the system is connected correctly. If everything is wired correctly, it is possible that you damaged your DUT when you accidently shorted + and - on the DUT. The always-on JS220 fuses are designed to protect your JS220, not your DUT. The user fuses exist so that you can set the appropriate thresholds to protect your DUT.

If you want to get more confidence that your JS220 is still working correctly, you can connect a resistor instead of the DUT for a quick test.


That is good news!

Still confused as to why this still happens, i changed the DUT to a different unit, this doesn’t solve the issue.
I tried with a simple resistor as you suggested, checked the wiring multiple times. This was a 68Ohm. power resistor. 12V = around 180 mA. still trigs the fuses and measures it to 11A as seen below.

It’s weekend time, so i hope we can continue the trouble shooting Monday

kind regards

Hi @MTychsen,

Well, that is strange. I confirm that 12 V with a 68Ω resistor should be 180 mA, not > 11 A!

It does sound like your Joulescope is damaged. I suspect that you completely blew up one of the MOSFETs or the 0.01Ω shunt resistor. If you open your JS220 and pull out the main board, do you see scorch marks or damage in this area: