Is there a list of support hotkeys for the Joulescope-UI?
I did not see a rapid table in the manual.

The only one I know is “space” (found here:
pyjoulescope_ui/joulescope_ui/ at 190c79c7cf9e2ebcaebcdfe9a8b436d0fc14edb0 · jetperch/pyjoulescope_ui · GitHub) which toggles the signal sampling stream.
Seems like all hotkeys are handled with the shortcut class.

Hi @MarcAndre

We do not have a list of keyboard shortcuts (hotkeys) for the the Joulescope UI. As of Joulescope UI 1.1.6, global shortcuts are:

UNDO: OS-specific key(s) = CTRL-Z on windows
REDO: OS-specific key(s) = CTRL-Y and CTRL-SHIFT-Z on windows
SPACE: start/stop sample streaming

The Waveform widget contains a few more:

*: Zoom to all
←: Pan left
→: Pan right
↑: Zoom in
↓: Zoom out
+: Zoom in
-: Zoom out

The UI currently does not have a non-programmatic way to add additional shortcuts or modify existing shortcuts.

Do you have any shortcuts in mind that might be useful to you?

Related to Streaming and inspecting data
I would like a button to toggle live/non-live(freeze current page) almost like “space”.
Scratch that, could “shift-space” (or other combo) “freeze” the current view.
Meaning removing the pin left/right. Toggling the same combo could pin back to previous value of pin.

The other one would be to add markers quickly.
I am not sure binding them to 1(single) and 2(dual markers) would be the best but its a start.

Sounds good and makes sense. I just added issue #268.

1 Like

We added this in UI 1.1.7, which is currently available as alpha. You can download here:

The Waveform widget now requires focus in order to capture the key presses. This fixes a problem where key presses no longer worked when you added two Waveform widgets.

We still do not have documentation for keyboard shortcuts, but you can find the Waveform widget key map for 1.1.7 here.

Tested 1.1.7 for this and something are amiss.
I can’t seem to hit Qt.Key_Asterisk or Qt.Key_Plus on an English Canada keyboard
(tried shift+8 for the asterisk).

Everything else seems to work as advertised.
The add x_markers do not seem to follow the mouse but only available placement in the middle of the screen. This could be an alternate style to snap the markers.

The toggle viewport does the trick!

Hi @MarcAndre - You are right. The 1.1.7 UI release does not correctly work with * or + on the normal keyboard or numpad. We just published a new 1.1.8 alpha here. See _keymap_load for the updated key mappings.

In addition to fixing those keys, it also uses the mouse location for add markers (s, d) and x-axis zoom (+, -)

1 Like

I validated 1.1.8!
Nice trick with the new markers.
Cheers M. Liberty.

1 Like