Joulescope JS110 measured current too high

I’m measuring the current my device is drawing, and it is higher than what the power supply (and a DMM) by about 50% (850mA vs. 550 mA). What can account for this?

BTW, I’ve placed the DMM after the Jscope tool and before my device. Both the DMM and the Powersupply current measurement agree. Jscope is high by more than 50%.


Hi @bbeck and welcome to the forum!

Are you using the original Joulescope JS110 or the new Joulescope JS220?

I’m using the JS110.


Ok, JS110 it is!

First, ensure that you are using the default current ranging settings, in case you have changed them:

  1. Are you measuring a target device that is also transmitting RF during the measurement?
  2. What version of the Joulescope UI are you using?
  3. Can you post a picture of the current waveform? Alternatively, you can email the image or small JLS recording to
  1. No RF
  2. 0.9.11
  3. attached…

In this case the PW supply and DMM are measuring 147mA

Thanks! So, your JS110 should be in the 2A range (assuming you still have Current Range set to auto), and should not be switching ranges based upon the waveform you sent. This eliminates a whole class of potential complications.

Here are some more things to try to help isolate the issue:

  1. Select ViewControl to add the Control Widget. Use the Control Widget to select each Current Range setting in 10 A, 2 A, and auto. Note the current in each setting. Do you get the same value for each setting?

  2. Can you send a zoomed-in image of the current waveform so that I can see the waveform variation? You may need to zoom all the way in.

  3. If you disconnect your Joulescope IN and OUT banana jack connections, select Current Range2 A, what do you measure? It should be 0.

  1. 10A - 879mA, 2A -883mA, auto - 850mA (more or less the same)
  2. attached…
  3. also attached

In that last image, your JS110 measures p2p=921 mA. Can you confirm that all cables were disconnected from IN+, IN-, OUT+, and OUT-?

I would expect a much, much lower value, like this:

I set current range to 2A and indeed got a p2p value of 17.5 mA.

And yes, the cables were unplugged.

So, how did you capture that last image with 921 mA? Can you repeat and post the image? Please keep streaming on so I can see the actual configuration.

If you were using current range auto, can you also add the current range waveform?

I had paused (hence the buffer)…

Can you turn off the voltage and power waveforms and add the current range waveform?

Ok, here it is:

Hi @bbeck - Well, that’s not right. The JS110 should autorange down to current range 6 (18 µA) with nothing connected. The most common cause of this failure is an overvoltage condition that damages one or more of the front-end MOSFETs that control the current range changes. This error can also explain measurement offset errors.

I will DM you in a moment.

Hi @bbeck - Just following up regarding your warranty replacement. Are you back up and running?


Yes thanks I’m up and running. One difficulty I had was getting the software going. Docs recommend Python 3.8, when I really had to use 3.10. Also, the default build wasn’t working with my platform (ubuuntu 20.04) due to glibc incompatibility. I had to build from source.


Yes, the only officially supported linux version is Ubuntu 22.04 LTS, and the linux distribution only runs there. You will need to run or build from python & the command line for all other linux versions. Follow instructions here but install joulescope_ui, not just `joulescope.

I recommend Python 3.10, but it should support Python 3.8 and 3.9, too. 3.11 is still too new for Cython.

I am curious. Do you happen to remember the issue you saw with Python 3.8?