Cannot run latest version 0.7.0 on iMac

macOS Mojave 10.14.6; turned off latest Parallels running latest Windows 10, rebooted macOS but same problem.

Problem: normally software “not from an identified developer” can still be run using an option in the Security & Privacy control panel. Somehow the new software triggers this response

Instead I get this message:


and cannot bypass the problem in Security

Going back to 0.6.8 still works and triggers the appropriate Open Anyway option.

Hi @RobR and sorry to hear you are having issues installing the Joulescope software on Mac. Have you tried holding the control key while clicking on the Joulescope software? You should then allow you to select “Open” , which then shows a dialog where you can select Open:

I don’t believe that the Joulescope software has changed with regards to Mac distribution since 0.6.8, but Apple has certainly adjusted their policies. We still have the action to ensure that the Joulescope UI software can be distributed more seamlessly on Mac.

yeah, I had this last week too, it’s new protections in Mojave.
IIRC last week, I got around this by opening System Preferences -> Security & Privacy, click the padlock to authenticate with your laptop, then re-run the Joulescope app which should bring up a prompt in SysPrefs>Security, for you to authorise it to run. Only need to do this once.

1 Like

Thanks @techydude for the tip! Have you tried Catalina yet with Joulescope? I have been concerned about switching over the MacBook Pro used to build the Joulescope software. I have read that Apple has become even more draconian about locking down Catalina, and every single release needs to go through their approval process, even if you are not distributing through the store. We paid the Apple developer tax, but it will likely take several days of effort to navigate the Apple release bureaucracy.

The Control Key tip worked.

Before, I did try what techydude suggests and it did not work for me.

But OK now, I can consistently open Joulescope.

Thank you

1 Like

D’oh. Sorry, I meant “it’s a Catalina thing”, 10.15. I got a new Macbook Pro recently, so was installing everything inc. Joulescope fresh (not from a backup) and stumbled over this, & read that it’s new app authentication requirements.

Following RobR’s reply, I just upgraded my work laptop to Catalina last night, so I’ll try the existing Joulescope app (0.5.x) and then 0.7 hopefully today, and report back if my technique really did work, or if there was a missing step.

I know some non-Mac software developers refer to this as a tax and a burden, but I ditched the shitshow that was Windows in 2007’s Vista, and I ain’t going back to having to run antivirus software that itself has become a risk exposure with too little efficacy. Having an “audit trail” to developers‘ identity is part of that chain of trust.

Matt and others:

Below are some preliminary testing steps I have done with Catalina on my AirBook. I removed all of the “programming” type software to get back to a more “pure” machine( removed: Arduino, Saleae Logic, LabRecon (which definitely crashes and burns under Catalina), Microchip MPLab, Simple IDE and BlocklyPropClient (Parallax)). There is almost nothing on this machine except Apple software (exception is Audio Hijack which allows me to increase the speaker output volume when watching Netflix video many of which have insufficient volume for my old ears to hear).

In all testing cases I removed the Joulescope app and any Joulescope folder (either in the Documents folder or one level up), and then restarted the machine. I was not able to locate any other files associated with Joulescope.

The following results were consistent several times and did not depend on the actual Joulescope being attached or not via USB. In all cases I never saw the “verifying software” message during install and never saw any Joulescope folder created.

AirBook is running Catalina 10.15.1 with all possible updates.

  1. Open and unlock Security & Privacy System pref.
  2. Open and drag Joulescope app to apps folder; then eject install disk.
  3. Open Joulescope app: always get the “cannot check it for malicious…”


  1. After clicking OK from that window, the Security window changes to this:

  1. After clicking Open Anyway, I get this window:


  1. I then click Open. At this point no apps are open other than Finder.

  2. Click on Joulescope app. It does open. I can the open and close it multiple times and get a Joulescope window.

I did not try recording any actual input signals. The Joulescope app does always recognize that the “device” is attached or not.

1 Like

I tried all of the above. Stil not able to start the program.
Mac Book Pro / macOS Mojave 10.14.6

I dont get the message in the security window or the “open” knob.

Hi @hansvz and welcome to the forum! Just to confirm, did you try holding the control key while clicking on the Joulescope software? Details were here:

@hansvz, assuming that you tried everything else, it would be interesting to see what the command line says. If you have homebrew installed, try running:


and post any console output.

I installed an older version 0.6.x that worked, Then went back to 0.7.0 and now that version also works?!

That is very strange, and thanks for the update. I definitely do not understand all the recent macOS changes. However, we will be working to get the Joulescope UI app signed through Apple. Likely not for the next release, but for the one after.