Can't launch Joulescope UI on macOS

Hi there,

I’m using a JS220 with a 2019 MBP (x86) on macOS 12.6.2. When I launch Joulescope UI versions 10.10-10.12, the oscilloscope view initializes, I’m prompted to upgrade the application version, then the screen flashes red, and the application crashes. I’ve also tried version 10.13 which appears not to launch successfully; the UI never appears. I experienced a similar issue last week when upgrading from 10.12 to 10.13, but downgrading resolved my issues. Not so this time.

I’ve tried connecting the USB cable through a hub or not, connecting to my work VPN or not, launching the UI with the JS connected or not, etc.

Has anyone with a similar configuration experienced this issue? Perhaps there’s a persistent configuration file somewhere that I could try deleting? For now I’m running 10.13 through parallels.

Hi @honeybee and welcome to the Joulescope forum!

We are working on improving macOS support, but it sounds like your computer is really not behaving. Check out issue #171 which describes our known issue with macOS support and annoying workaround.

For what it’s worth, one of our build & test computers is a MacBook Pro 2018 Intel x64 running macOS 13.1.

You can clear the Joulescope UI configuration information if you want. You can delete all the subdirectories under ~/Library/Application Support/joulescope. The macos_12_0_x86_64 version 0.10.13 should work as it was built with macOS 12 compatibility. Download
here, or use this direct link to macos_12_0_x86_64 0.10.13.

If it still does not work and you have homebrew installed, you can try launching it from the command line and see what it outputs. The path to launch the Joulescope UI is normally /Applications/joulescope.app/Contents/MacOs/joulescope_launcher.

Hi @mliberty, thanks! I cleared all of the Application subdirectories. Initially this did not work, so I again downgraded from 10.13 to 10.12. After having read your workaround I’d guess that there had been an issue with my widget arrangement that caused the crash each time I launched the application. 10.13 seems to have a separate, unique problem preventing it from launching.

1 Like

Great to hear that your machine is working with 0.10.12, @honeybee.

For macOS with the JS220, the only difference between 0.10.12 and 0.10.13 is that 0.10.12 was built on macOS 12 and 0.10.13 was built on macOS 13. Ugh.

The good news is that we have a solution to #171 in progress. The bad news is that involves significant changes to how we manage widgets, so it’s tied to a bunch of other changes. I hope to have an alpha early next month (Feb 2023).

Sorry to be the bearer of bad news! I look forward to the widget overhaul. Thanks again!

1 Like