Firmware Update Failed w/ UI version 0.9.2

Failed to update firmware; got stuck at 9%. Waited for 15+ minutes and then hit the X in the upper right corner to try again. After opening and closing Joulescope UI and unplugging the USB cable & attached power I am not able to resuscitate.

Poked around on the forums for a bit and tried some .inf stuff from the other firmware update failed thread, but that didn’t seem to work.

Anyways, any help would be greatly appreciated to get my wonderful Joulescope back up and talking.

Running on Windows 10 Pro 64-bit


-Mike T

Hi @Mike_T - Welcome to the forum, and sorry that your first post is about a firmware update issue.

Thanks for trying to debug this issue. Win 10 x64 should be just fine out of the box without any additional INF files. It looks like your Joulescope is quite happy, and staying in the bootloader. Let’s just try again. Disconnect the USB cable from your Joulescope (I know what the warning says, but it’s very hard to brick your Joulescope :smile:). Restart the UI. Connect your Joulescope to USB. What happens?

If the firmware upgrade still fails, could you click Help → View logs… Then close the UI and post the most recent log. If you would rather not post publically, you can email it to sales a t

Also, the full firmware update only takes 30 seconds or so. If it gets stuck again, no need to wait for longer than that.

After trying again to disconnect the USB cable, Restarting UI, and then replugging in the USB cable nothing happens as before. The green LED does not turn on and there are no indications of any communication working between windows and the Joulescope.

New user, so I can’t upload attachments. I will e-mail.

Hi @Mike_T: I have Joulescope on the brain and gave you the wrong email address. The right address is:
sales _ a t _

I also upgraded your account so that you should be able to upload it, too.

That’s unexpected. The USB-side “status” LED should fast-blink while in the bootloader. Is it still showing up in the device manager as you posted earlier?

Also, what is your Joulescope’s serial number (see the nameplate label on the bottom)? This unit doesn’t happen to be a beta unit (serial number < 100) by any chance?

Serial number is 721, so I guess not a beta unit. I forwarded the e-mail to the jetperch address.

My observation is nothing works, led never comes on…no activity in the UI, etc. All after upgrading to latest UI and trying to update firmware as prompted.

Yes, still showing up in device manager under Windows 10

After talking to mliberty out-of-band (via direct e-mail), he mentioned an errata with the USB uC that has this behavior.

Anyways, after unplugging the USB cable from my docking station and plugging it directly into my laptop I was able to upgrade the firmware and start running again as normal.

Thank you for your help and great product Joulescope team!

Here are some more details regarding this issue for future reference.

When performing a firmware upgrade, the upgrade stops around 9% or 10% and does not progress.
The “Status” LED next to the USB connector is not illuminated.

This behavior is intermittent, and depends upon the Joulescope device, the host computer, and the host USB port!

Note that a normal firmware upgrade should only take 30 seconds, so waiting longer will not help.

Units affected
All Joulescopes shipped before approximately Aug 1, 2019, which includes all Kickstarter units. Since @Mike_T’s unit was shipped after this time, we now suspect that some units may not have had the fix applied.

Unplug the Joulescope’s USB cable from your host computer. (you can safely ignore the warning). Try plugging it into a different port on your computer. Does the firmware upgrade work? Try different ports until it does. If no ports on your computer work, can you try with a different computer?

The NXP LPC54608 microcontroller used by Joulescope for the host USB connection has an errata:

Although we were aware of this errata, the document at the time said that is was fixed in the SDK software platform. Turns out, it was only implemented in this single SDK example as now indicated by the errata. After producing the Joulescope units, we found several units that we could not program in the factory, and traced the root cause to this errata. We issued application and bootloader updates that include this errata workaround.

If your firmware update failed after 20% completion, then the JS110 host-side microcontroller firmware likely succeeded and the “Status” LED next to the USB connector should illuminate. The sensor-side microcontroller firmware update likely failed. You may be able to fix this by forcing a new firmware update:

  1. Disconnect your Joulescope’s USB port from the host computer.
  2. Start the Joulescope UI
  3. Select File → Preferences → Device → firmware_update → always
  4. Connect your Joulescope’s USB port to your host computer.
  5. Wait for the firmware update to complete.
  6. If not successful, try on another USB port of your computer. If that still doesn’t work, close the
    Joulescope UI and post the log file.
  7. If successful, restore the standard settings. Select File → Preferences → Device →
    firmware_update → auto