Joulescope requires plugging in USB cable on launch of PC

Hi there,

I noticed that on my Windows PC running GUI 0.9.7, driver 0.9.6 that when my Windows PC boots, the device under test is disconnected from power because the Joulescope is not on until I unplug/plug in the Joulescope USB cable. THEN the device under test is powered on. But I notice I don’t have to unplug/plug the USB cable on Mac. Is this behavior Windows only?

Hi @andrewhh

Your Joulescope does disconnect IN+ from OUT+ when the sensor-side is not powered. When the sensor-side is powered, your Joulescope illuminates the sensor-side green LED. For the default banana jack front panel, the LED is under the “IN” label.

Normally, the sensor-side is not powered. Windows does perform automatic USB enumeration, which illuminates the host-side STATUS LED. However, Mac and Linux defer this operation, and the host-side Status LED remains unlit. When you discover and open the device, either in the Joulescope UI or your own script, it will normally power on the sensor-side. At this point, both LEDs will illuminate. However, you also need to ensure that the Current Range is set appropriately, and “auto” is recommended. “off” disconnects IN+ from OUT+, and other manual settings could brown out your target device depending upon your setup.

Are you saying that you have the Joulescope UI running, and your Windows machine still requires USB unplug/replug before connecting to the device? If so, could you try to repeat this behavior, but ensure that the Joulescope is connected directly to a USB port on your Windows computer, no USB hubs or docks?

My complaint was that the Joulescope seems to have trouble connecting to my PC after the PC restarts. I could previously unplug then plug the Joulescope USB cable, but now I am doing that and the Joulescope remains “USB Device not Recognized” and the Joulescope GUI does not see the Joulescope device.

No USB hub in use

Hi @andrewhh

That is very odd. Joulescope should definitely not need to be unplugged and replugged after the host computer powers on.

When you power on your PC, does the Joulescope Status LED next to the USB connector ever illuminate? On Windows, it should illuminate even without running any other software.

It sounds like unplugging and replugging your Joulescope fixes allows your Joulescope to enumerate. If so, then one of the most likely differences is USB power, such as voltage or current limiting. The only issue I can think of is this, but it only affects a small subset of units. The fix does affect the Joulescope’s power-on current draw, and it should actually be better on any Joulescope. You can try and see if it makes any difference.

I tried doing the firmware update with the Joulescope in the “USB Device not recognized” and it failed.

I plugged in the Joulescope to another computer and back to the original computer and it works again. Hopefully I don’t have the issue when the computer reboots.

I tried doing the firmware update again with the Joulescope streaming data and it also failed.

Hi @andrewhh - Joulescopes open exclusive. You cannot have anything else connected to them, including the Joulescope UI, when starting the firmware update. Based upon the info you provided, your Joulescope was not upgrade.

This approach is definitely not the easiest, but you do get this error if you did not download the “img” file to your Downloads directory. Could you confirm that you downloaded “js110_1_3_4.img” to your Downloads directory? Alternatively, you can change the command to where the file actually is.

I disabled Joulescope GUI, moved the IMG file and did the command again, got the error and the firmware updated successfully. Contradiction but hopefully the Joulescope enumerates every time now. :grinning:

Video Joulescope firmware - Google Drive

Hi @andrewhh

Please close the Joulescope UI when performing the firmware update. Otherwise, the Joulescope UI will interfere with the update process and potentially take over. You are attempting to upgrade to firmware 1.3.4, not the 1.3.2 that is currently included in the Joulescope UI.

The firmware updated to 1.3.4 successfully

1 Like

Excellent! Please let me know if it makes a difference.