Intermittent USB connection

Two Joulescopes intermittently fail to connect to my Windows 10 PC. The green light remains unilluminated after connection and I repeatedly hear repeated tones (indicating a new USB connection). The logs show the retry pattern, too. The cycle below repeats indefinitely when the connection fails.

WARNING:2021-03-25 09:04:49, failed 1: usb control transfer failed: [1] Incorrect function.
WARNING:2021-03-25 09:04:50, failed 1: usb control transfer failed: [1] Incorrect function.
WARNING:2021-03-25 09:04:50, failed 1: usb control transfer failed: [1] Incorrect function.
INFO:2021-03-25 09:04:51,
WARNING:2021-03-25 09:04:51, failed 1: usb control transfer failed: [1] Incorrect function.
INFO:2021-03-25 09:04:51, start
INFO:2021-03-25 09:04:51, start
INFO:2021-03-25 09:04:51, device = Joulescope:002180, False
INFO:2021-03-25 09:04:51, done

Today, I was finally able to restore communication by connecting directly to my PC. My USB hubs are all externally powered, so should be capable of supplying necessary power.

Previously, rebooting my PC didn’t remedy the problem.

Hi @rlambert and welcome to the forum! The behavior you describe when plugged into the hub certainly sounds like your hub is not providing enough current to the Joulescopes. Your Joulescopes will draw 500 mA peak when they first power on, but then draw about 250 mA under normal operation. If you add up all the current drawn by the devices attached to the hub, does it exceed the hub’s maximum current? If you disconnect all other devices from the hub, do you see the same behavior?

We do recommend connecting Joulescopes directly to a USB connection on your computer. In addition to power issues, there are lots of bad USB hubs out there that can cause communication issues, especially for Joulescope’s 8.2 MB/s when streaming.

Thanks for the prompt advice, Matt. I’m prone to suspect USB hubs, too, but they usually work. Most days I can use the Joulescope without any disruption. I intentionally bought beefy powered USB 3.0 Hubs from a video and photography store. They have dedicated charging ports.

Moreover, my Microsoft Surface docking station also wouldn’t work. Its “brick” can charge my 15-inch laptop, so should be able to spare a measly 500 mA.

Is there anything in my startup sequence that might precipitate the cascading failure? For example, I might have left my Joulescope connected when I powered my laptop down at night. Thus, it was still connected when I rebooted in the morning. On days when my Joulescopes worked “out of the box,” it might be because I literally took them out of the case midday, when my PC had already enumerated all the other connections.

Connecting to my laptop is a long stretch. Are there any tricks to restoring communications? I tried deleting the drivers today. No luck.

Hi @rlambert Your Joulescopes are designed to support USB suspend and resume, so it should not be an issue if your computer goes to sleep when your Joulescopes are connected. If you are capturing data, you definitely want to turn off sleep & updates. I have taken to disconnecting the network, just to be sure Windows Update doesn’t take over.

I don’t know of anything that would cause a cascading failure. The NXP chip we use does have errata USB.6 regarding USB high-speed detection.
Without any workarounds, it also can result in this perpetual reconnection mode. However, the firmware includes a workaround. I suppose that it’s possible that the workaround does not work on your hubs. I haven’t heard of the workaround not working with anyone else, though.

Another thought is USB power management. If you go to “Power & Sleep” settings, “Additional power settings”, “Change plan settings” on the active plan, then “Change advanced power settings”. Try turning off “USB selective suspend setting”:

Turning off PCI Express Link State Power Management may also affect USB.

Not sure if those settings will help, but it’s something to try.

Thanks again, Matt. I’ll keep wiggling the tooth until it comes loose. I’ll report if I learn anything.

1 Like