Multimeter works, Oscilloscope doesn't?

(Aside: I’m loving my new JS220 and all the detailed insights to low power circuit design it brings. When it works. :wink:)

I’m using my JS220 to measure power and to monitor a few GPIO pins. It worked fine in Oscilloscope mode until this morning. But now, clicking on the “streaming” button has no effect other than the button changing from “play” to “pause” – no streaming data appears. I haven’t changed the wiring or anything external things that I know of that would cause it to stop working.

Multimeter mode works just fine – all the numbers look about right. In Oscilloscope mode, I DO see the GPIO indicators in the Device Control tab flickering, but nothing is drawn on the main screen.

One thing I wonder about is the fuses: When I click on the Device Control icon, Fuse 1 and Fuse 2 are grayed out. The wording is a bit ambiguous, but I think that’s the “normal” state.

Ultimately, I’m 80% sure this is just a user error (me). Am I missing something obvious? Or are there other things I should do to diagnose the issue?


How did I forget forum etiquette? Here’s the environment in question:
Version Information:

UI 1.1.6
driver 1.5.1
JLS 0.9.3
Python 3.11.9 (tags/v3.11.9:de54cf5, Apr 2 2024, 10:12:12) [MSC v.1938 64 bit (AMD64)]
Platform Windows-10-10.0.22635-SP0
Processor Intel64 Family 6 Model 142 Stepping 10, GenuineIntel

In the immortal words of Homer Simson: DOH!

Solved. In the Device Control windows, although [P] was enabled, neither [I] nor [V] were enabled, so of course it didn’t get any power data.

UI suggestion: perhaps put up a warning if the user is trying to view power data but has not enabled current and voltage sensing?

Hi @rdpoor - Welcome to the Joulescope forum, and congrats on your new JS220! Thanks for selecting a Joulescopes, and I hope it helps you with many future low power circuit designs!

The easiest way to confirm the instrument is working is to inspect the LEDs. Both the Controller Status LED and the Sensor Status LED should be green.

Even when a fuse engages, the JS220 still provides data. Both the Multimeter widget and the Waveform widget will still update. However, the current will be very, very small.

My first guess is that you have inadvertiantly disabled all the signals being displayed. You need to have the desired signals enabled in both the Device Control widget and on the Waveform widget, like this:

You can fix most configuratio problems by reverting to the default config, as long as you don’t care too much about yoru UI configuration. You can select FileClear config and exit. Then restart the UI.

If that still does not work, select HelpReport Issue, and submit a new issue. Please include this forum post URL in the description so we can match up the issue report.

Ahhh… this problem is issue #221!

For the time being, the workaround is to enabled all threee signals i v p when you want p.

1 Like

I managed to post my solution moments before yours hit – sure enough, I’d neglected to enable the [I] and [V] inputs.

Note also my UI suggestion to put up a warning if the user is trying to view power data without enabling the current and voltage inputs.

Thank you for the prompt and thorough reply!

1 Like