Running Joulescope UI on MacOS Ventura (13)

Has any one managed to get the Joulescope UI running on MacOS Ventura (MacOS 13) ?

I have had the UI working on this machine, this was on MacOS 12 but I cannot get the application running on MacOS 13.

The application starts (the icon appears in the Dock temporarily) and then seems to exit.

I have the Python scripts seemingly capturing data OK, I am getting what looks like sensible data from the script. So am thinking that the drivers are installed OK.

I have tried deleting the UI application and downloading the latest (stated as MacOS 12 download, I can’t see a MacOS 13 download) and reinstalling and I still get the same result, the UI starts and exits.


Hi @Nevyn and welcome to the Joulescope forum!

Joulescope UI version 0.10.8 now runs on macOS 13. Note that the 0.10.x releases use a new C driver backend which supports the new JS220. It still supports the JS110.

We have not yet switched the default download over to 0.10.x yet. For the time being, you can download it here. We do plan to make this (or a future version) available on the main download page by this Thu, Nov 3.

We have tested UI 0.10.8 on both arm64 and x86_64. Let me know if it works for you!

I can confirm that 0.10.8 x86 version is running on Ventura.

Thank you for your quick response,

1 Like

Great! While everything should run correctly with Joulescope UI 0.10.8, we are still testing JS110 support. If you run into any issues, please don’t hesitate to let me know!

Is just using these forums OK or is there anywhere specific you want reports logged?

I think I have found an issue.


You can use whatever is most convenient for you. If you are comfortable with GitHub, you can create a new issue. You can post here or send a DM here. You can email support at Either way, we will work to figure out the and fix the issue.