Software Not Running on Win 7 x64

Hi @Philip,

Great to hear that this worked for you! It looks like some driver installation on your Win 7 PC (perhaps that STLink dongle) installed the WCID Device discovery for WinUSB, but not enough to populate all the information from the USB descriptors provided by Joulescope. This condition is one that I have not yet encountered with Win 7, so thank you for taking the time to provide the detailed description!

OK here’s what worked for me; on Windows 7 Ultimate:

  • initial plug-in installed driver “HP Printer (BIDI)” – meaning “bidirectional” maybe I assume
  • Device Manager / Update Driver / Browse (to my C:…\Joulescope folder) / did not change
  • Device Manager / Uninstall / unplug / replug / just got same driver again
  • Device Manager / Uninstall with [x] Delete the driver / unplug / replug / started “Searching Windows Update”
  • I interrupted (STOPPED) the WindowsUpdate step, and now suddenly I have “WinUSB Device” and readings appearing.

I just received the Jooulescope and I tried to install it on Win7 x64, but I get the yellow band and no driver found. I downloaded your inf file and I can see the USB ID in device manager matches your inf file so I don’t understand why it would still say it can’t find a driver for it. I also disabled testsign on, but some reason it thinks your driver file doesn’t apply to it.


Hi @Gary and welcome to the Joulescope forum! Would you mind right clicking on Joulescope, click Properties, and then post what you see. You can use the “Snipping Tool”. Hopefully the “Device status” has some indication of why your computer is not happy. Here is what I see on Win10 x64:

Hi Matt, Thanks for the quick response. Actually I found the issue. It was silly. I thought the file downloaded it as a .inf file. Actually it was downloaded as joulescope.inf.txt and I had file extension hidden by default. So I assumed it was a .inf file. After correcting extension, it installed and it’s working now. Thanks though for the help!

1 Like

Hello All, Searched and can’t find a more recent topic, but I am running Win7 x86, and following downloading and installing joulescope_setup_0_9_3.exe
When Opening joulescope.exe, I first get popup “System Error” - “The program can’t start because api-ms-win-core-path-i1-1-0.dll is missing from your computer. Try reinstalling to fix this problem.”
I click OK then NEXT am hit with
“Fatal Error Detected” popup, which indicates:
"Error loading Python DLL ‘C:\Program Files (x86)\Joulescope\python39.dll’. LoadLibrary: The Specified module could not be found.

#Cheeky: Thankfully, the driver problem was resolved by manually downloading and installing the 2 .INF files posted by mliberty in Jun '19. After finding this forum, I can verify the hardware is recognized as a WinUSB device.
Now, if only the Sys dll and Python errors would go away. #WhySoHard

Hi @Mark and welcome to the Joulescope forum!

Did you really mean Win7 x86 (32-bit)? The Joulescope UI distribution is only for 64-bit.

Although we no longer support Win7 or 32-bit, it may still work if you want to run directly from python and compile locally. Check out this old post for some completely untested and possibly incorrect hints.

Hi mliberty, it is 64-bit Win7 with all last updates. Is a machine with >4GB main memory (requiring 64); and is used for running python scripting environment for data acquisition and instrument control over USB.

Have you seen this error before:
“System Error” - “The program can’t start because api-ms-win-core-path-i1-1-0.dll is missing”??

Hi @Mark

Ok, Win7 x64 (64-bit) has a much better chance of working. However, we no longer support it, and neither does Microsoft.

I have not heard of this error before. I know that people ran the Joulescope UI on Windows 7 x64, at least a while back. We have not been testing on Windows 7 x64 for the past year.

I did some research, and Python 3.9 dropped support for Windows 7 (see this). The latest Joulescope UI 0.9.3 build uses Python 3.9. You could try Joulescope UI 0.9.2 (download). Not sure if this is the issue, but its something.

Google also indicates that this is a common problem. Perhaps one of those solutions helps?