Constant Scale Jumping

I have the current range set to 180mA and the voltage range set at 15V. With auto ranging is turned off, I expect that the Y axes will remain fixed and stable, yet with these settings, the Joulescope display continues to do a veritable St. Vitus’ Dance of constant display changes, as shown in this GIF

Neither parameter’s display seems to be honoring its range setting.

@JuliaTruchsess I don’t have a fix but I have experienced this. It seems that the gui range is set by the max current, which continues to be the case when we turn off the max/min lines. If you turn them on do they appear to be what’s driving the auto range?

1 Like

Hi @JuliaTruchsess and @simonmerrett: The y-axis waveform range and the Joulescope current selection autoranging are two independent features. The y-axis waveform will autorange to the max and min lines, even when they are not shown. I should fix this. If you want to disable the y-axis waveform autoranging, right click on the y-axis. Select RangeManual.

You can then hover over the y-axis and use the scroll wheel to zoom in/out, and the click and drag to move up/down.