GPIO in UI not displaying correctly

I’m having trouble getting the GPIO’s to show up in the UI and when they do - there’s no way to adjust the scaling or zero point. I thus can see when it’s low, but when it’s high…

Is there documentation somewhere about getting this working. It seems to be missing from the user manual.
I’m using 1.0.29 of the UI

Hi @g.mtl - It appears that your Joulescope UI instance is somehow in manually ranging mode on GPI 1. The UI is designed to prevent this, but something must have been confused.

Before you do anything else, would you please:

  1. Close the Joulescope UI.
  2. Open the Joulescope UI.
  3. If the issue persists, select HelpReport Issue so that I can take a look? Please note that this report is for

Do you know what actions you took to get to this point? I would like to duplicate this if possible. We test for this. I also just tried a bunch of random actions, and I could not get this to happen.

Does clicking the Y zoom all button fix this?

If you don’t care much about your configuration, the quickest way to fix this is to select FileClear config and exit, restart the UI, enable the GPI in Device Control, select ViewOscilloscope, and then enable the GPI. Does this fix it for you?

Closing and reopening the UI did nothing towards fixing the problem. :frowning:
I do care about my configuration, but you’re last suggestion fixed the problem. In hindsight it probably would have made sense to stash the current configuration somewhere before wiping it out.
Thanks for your help.

Great to hear that it is working! Please post again if you run into this issue.