App crashes on Mac

Appv0.9.7 crashes on Mac v11.6.2 when opened in Oscilloscope mode with Joulescope connected.

Screen Shot 2022-01-27 at 12.39.45 PM

The following workaround seems to work currently.

  • Force quit app

  • Disconnect Joulescope

  • Open app

  • Change to the multimeter

  • Then connect Joulescope

Hi @tmbraja - Welcome to the Joulescope forum, and sorry to hear that the Joulescope UI is crashing.

If I read that correctly, the Joulescope UI is consuming 118.6 GB of RAM. You didn’t happen to adjust the Joulescope→ Preferences → Device → setting → buffer_duration, did you? The default is 30 seconds and requires about 1 GB. The Joulescope UI allows you to set this bigger, but may consume more memory than your computer has. Note that the UI has separate preferences for Multimeter and Oscilloscope, so you have to fix both.

If you want to completely revert to the the default settings, you can delete the configuration file:
~/Library/Application Support/joulescope/config/joulescope_config.json

Does this fix the problem for you?

Yup, That was it. Thanks. It seems to work after I reduce the buffer duration.

A follow-up question, we run a 24hr test to help with battery life projection. We would like to capture the oscilloscope current waveform for the whole 24hrs. I tried to use the record option but wasn’t able to open the file and review the waveform. How do you suggest we achieve this?

Great to hear that fixed the problem.

You should be able to record to a JLS file and then open the JLS file to view it. What exactly didn’t work for you? Does the JLS file exist? If so, what exactly happened when you tried to open it? It can take up to a minute to open large JLS v1 files.

Note that a 24-hour recording at the full sampling rate requires about 700 GB, so make sure your host computer has enough storage. You can reduce the sampling rate for less data. See PreferencesDevicesettingsampling_frequency. Many customers are happy with 10 kHz for longer recordings.

We also have a new JLS v2 file format that is much faster. The Joulescope UI does not yet record to JLS v2, but it can open and display them. To record, you need to use a python script, like with the --jls 2 option.