Joulescope app Python exception - Unable to allocate memory for an array with shape

Hi,

I am using Joulescope JS110 and untill now I had no issues with it, but unfortunately recently an error is appearing when right after the Joulescope app starts, making the Joulescope unusable. The intresting part is that two, maybe three months ago the exact same device was working perfectly fine on my computer. The only thing that has changed since is that I restored the whole system from a copy, as I was changing the main hard drive for a bigger one.
I’ve also tested this device on my co-worker’s laptop and it works perfectly fine, so the problem is probably related to my laptop exclusively.

The error that i’ve found:
ERROR:2023-01-09 08:31:21,254:main.py:888:joulescope_ui.main:while opening device JS110-002034
Traceback (most recent call last):
File “joulescope_ui\main.py”, line 886, in _device_open
File “joulescope\v1\device.py”, line 371, in open
File “joulescope\v1\stream_buffer.py”, line 64, in init
File “joulescope\v1\stream_buffer.py”, line 74, in _update
File “joulescope\v1\sample_buffer.py”, line 48, in init
numpy.core._exceptions._ArrayMemoryError: Unable to allocate 8.94 GiB for an array with shape (2400000000,) and data type float32

So far i’ve tried reinstalling the Joulescope app and resizing the windows paging file. Nothing worked.
Thanks in advance.

Link to whole logfile (I can’t upload it as a file (new user …) or as a text (too many characters):
Logfile

Hi @Marcel and welcome to the Joulescope forum! I think that you may be running into issue #172 Can select excessively large RAM buffers causing app to crash.

If you don’t care about the existing Joulescope UI configuration, the easiest way to fix this is to delete all Joulescope UI configuration data. Here’s how:

  1. Close the Joulescope UI

  2. Navigate to the Joulescope UI configuration directory. In Windows, you can use Windows File
    Explorer, in the Navigation bar, enter:

     %LOCALAPPDATA%\joulescope
    
  3. Select all subdirectories and press delete.

  4. Start the Joulescope UI

Does this fix the problem for you?